When opening Management Console then getting error "LicensingEngine.IncorrectLicense"

When opening Management Console then getting error "LicensingEngine.IncorrectLicense"

Version: 

iVend 6.6

Issue: 

When opening Management  Console then getting error "LicensingEngine.IncorrectLicense", below is the screenshot for the same:


Machine Application log displays :-
Faulting application name: iVendLicensing.exe, version: 1.0.0.0, time stamp: 0xc6fb878d
Faulting module name: lmgract_libFNP.dll, version: 11.12.1.0, time stamp: 0x53216679
Exception code: 0xc0000005 

Root Cause: 

Perpetual license missing in the License administration tool.

Solution:

1. One of the issues with the customer, it was noticed that the perpetual license was missing in the CXS License Admin tool and it was causing the error.So need to check and verify the activated licenses in the system and if the perpetual license is not activated then activate it and this should fix the error.If we follow above step and error still remain same.
Further need to check Application log and if it showing below same Error (It seems some file corrupted).


2. Based on application log ,as workaround need to  re-install the iVend by below steps:- 
  1. Just uninstall iVend from control panel on the problematic machine. (DO NOT DELETE ANY DATABASE)
  2. Delete ONLY iVend Retail folder from C Drive.
3: Restart Machine.
4: Run the iVend same version installer again.
During the installation setup "Custom Installation Option" and select the component one by one which you want to install.
5: In between installation it setup will ask you to "Create New Database" & "Use Existing Database"
Please Select "New database" option and create Dummy Database (like CXSRetailDummy) Because we are just creating new files.
6: After completing the installation fill the connection manager, Integration Service, and Replication Service with existing Production Database details. Then try to login in MC and check.

 

Note : If still error remains same, then need to change other (new) machine to resolved this error.