System.Data.SqlClient.SqlException (0x80131904): Execution Timeout Expired

System.Data.SqlClient.SqlException (0x80131904): Execution Timeout Expired

Problem Statement

Getting an error message "System.Data.SqlClient.SqlException (0x80131904): Execution Timeout Expired. 


The timeout period elapsed prior to completion of the operation or the server is not responding." in the iVend integration failure monitor


Cause

Such exceptions could be momentarily and might have caused because of extended wait time for record processing


Procedure to fix:

Follow the below steps to reprocess the record.


1) Stop the integration Service

2) Clear the Temp folder where iVend Integration Service is configured

3) Restart the affected machine once.

4) Restart the SQL Server once.

5) Update the integration Service

6) Start the integration Service

7) Retry the failed records from iVend Integration Failure log screen and check.