Slowness in the printing of the Transaction Report

Slowness in the printing of the Transaction Report

Product Version:

iVend 6.5.6


Problem statement:

The customer has started facing the issue while printing the transaction receipt at their stores. Initially the transaction receipt was taking 2-3 seconds but after sometime it started taking 12 seconds or more.


Cause:

There were 2 cause for this issue:


  1. The provided custom transaction receipt query was not optimized, and

  2. The customer was using SQL EXPRESS edition at their stores where the space utilization for the SQL was 9600 MB (9.6GB / 10 GB max limit from Express edition)


Resolution:

To fix the issue following has been done:

  1. The report team provided the optimized query with the report, and

  2. The customer purged the data from the stores to create the space in SQL EXPRESS edition.


After performing above 2 steps, the issue has been resolved at customer with the required performance.


    • Related Articles

    • Multiple Receipt Printing issue

      Environment: iVend 6.6 7989 SAP B1 10 Problem Statement: iVend is sending lots of receipts for single transaction until printing has to be stopped. Symptoms: It was observed that for Receipt ID ‘Transaction receipt’, Transaction receipt was selected ...
    • Transaction Receipt not Printing KSA QR Properly

      Problem statement : In transaction receipt KSA QR not printing properly iVend version : 6.6 8864 Symptoms: NA Resolution / work around : Follow the steps to resolve the issue. 1: Make sure Customized Report is attached in the Print Profile. 2: ...
    • Logo Printing on Transaction Receipt

      iVend POS – Printing the Company Logo on the Thermal POS Receipt How to Configure the Logo for Printing on the POS Receipt Follow the steps mentioned below to configure the logo for printing on the transaction receipt. 1. Log into the Management ...
    • X-Tape Report

      iVend Retail – X-Tape Report In iVend Retail the X-Tape report enables the POS user to see a summary of the POS Till in use. The X-Tape report is available from the Point of Sale “User Menu”. This is accessed by clicking on the iVend Retail Logo ...
    • Logo not printing on Transaction Receipt

      Product Version: iVend Retail 6.6 7915 SAGE300 Problem Statement: Logo map in Transaction Receipt IRT, however it is not coming in Transaction Receipt PDF. Proposed solution/Workaround: Follow below steps to solve the issue. Login in iVend Enterprise ...