Sale record stuck in integration :DI: [RIN1.AcctCode][line: 1] G/L account is missing (1)

Sale record stuck in integration :DI: [RIN1.AcctCode][line: 1] G/L account is missing (1)

Product Version:

iVend 6.5 update 6 Patch 2, with SAP B1


Problem Statement:

Sale Transaction with both,  Sale and Sale return as line items, stuck in integration.

Symptom: Integration record stuck with below error: 


System.Exception: DI: [RIN1.AcctCode][line: 1] , 'G/L account is missing (1)'" StackTrace: at ReplicationSBOIntegrationWinSer.IntegrationObjects.Base.CreditMemo.CreateCreditMemo(DataRow[] objDataRow, DataRow[] objDataRowSurcharges, DataSet ObjDataSetTransactionAttribute, DataSet ObjDataSetTransactionLineAttribute, Decimal passedRoundingAmount, Decimal & roundingAmount, Boolean& isRolledBack) at ReplicationSBOIntegrationWinSer.IntegrationObjects.Transactions.Replicate(Direction From, Direction To, Int32 DatasetRowID)at ReplicationSBOIntegrationWinSer.Integrator.MainStart(DateTime LastRetryAt, Boolean& Retried)"

 

 

Possible Cause:

Below are the possible causes of this issue.


1. Accounts for the store should be mapped with the Dropship warehouse.


2. In case the Warehouse/Customer/item does not exist in SAP and correlated accounts.


3. In SAP at warehouse screen >>Accounting tab - G/L accounting is not defined.


4. In SAP at Administration >> Setup >> Financials >> G/L Account Determination is not defined.


5. IF Freight accounts are not defined in SAP.


6. IF Tax code accounts are not defined in SAP.


7. If the “Inter Store” setting is enabled in the Retail Setting screen in SAP.


Note:- If the “Allow Inter store transaction” setting is enabled, then please confirm from the customer if they are using the inters-tore feature in SAP. If it is not used then this configuration is not suggested to be used.



Point 1:

If the Customer is having a single store then there is no need to have this setting in place. So in such case uncheck this setting as per the below Screen and save the details.


Note: Before Disable the setting of “Allow Inter store transaction”, Please fist stop the integration services.



Point 2:

If  customer has multiple stores and he wishes to use  “Allow Inter store transaction” setting then we need do further investigation based on the below keys checkpoints: 


a). Check Sales Accounting-(order) is correctly mapped.


b). Check Sales Refund Accounting- (Sales with Fulfillment) has correct mapped.


c). Check Sale Refund Accounting-Sales has correct mapped.


d). Check COGS Accounting for Refund is correctly mapped.



Workaround/Resolution:

In this case, the customer was using a single store, so there was no need to enable this “Allow Inter store transaction” setting, we disabled this setting as per the below screenshot and retry the records from integration monitor, records were successfully integrated.