Replication is not working for Offline POS

Replication is not working for Offline POS

Problem Statement: 

Replication is not working for Offline POS as shown below (Connection status Is Red):


Symptoms: 

Below are the known symptoms:


  • API Service is either not configured or working properly.


  • IIS (Internet information services) is not installed on the server.


  • Replication service is stopped or not configured properly.


Resolution/Work Around: 

Below are the possible workaround or resolution points:


  • Go to the Management console of Enterprise/Store (For which the offline POS is configured) >Administration > IT Administration > API Health check > If the API Health check is successful then API service is working fine otherwise please check the API service configuration.


  • Please try to ping the HO IP/Store IP (For which the offline POS is configured) from the offline POS server and check if they are pinging successfully or not.


  • Restart the IIS and iVend Replication service in both the servers.

 
Case Study:

Incident: INC0027705


Version: 

iVend DemoStack 6.6


Issue: 

Replication is not working for Offline POS.


Cause: 

API service was not configured at Enterprise (Offline POS was connected with Enterprise).


Resolution: 

Configured the API Service and Reinitialised the Offline POS after which the issue was resolved.

 


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