Optical transaction Tab not showing in Ivend management console
Product version:
iVend 6.6 Patch 7825
Problem statement:
Optical transaction Tab not showing in ivend management console
Scenario:
Optical transaction TAB is not showing in ivend management console in one of the location.
Observation:
Checked the table Cfgaddon and u_opt_sysinformation and found that the addon was connected and license was also working on the system.
Further it was found that in the program data directory there were instances of previous add-on; These dated add-on instances was restricting the new add-on file to initiate on the system; so the customer was facing the issue.
Cause:
Multiple Add-on instances were found in system causing the add-on to not work correctly
Proposed Solution/Workaround:
Troubleshooting Steps
1) Check the user roles for that particular user for which login into client machine.
2) Check the add-on connectivity and license with the help of below queries.
Used below queries for same:
a) Select * from cfgaddon
b) Select * from u_opt_sysinformation
Removed the previous add-on from below location and restart the MC again.
C:\ProgramData\CitiXsys Americas, Inc\CitiXsys - iVend Management Console\6.6.7425.36677\iVendAddOn
Once HO MC was restarted the new add-on file automatically created at above location.