Not able to Login. Getting an error "User doesn't have login rights"

Not able to Login. Getting an error "User doesn't have login rights"

Problem:

At login time a user may face a situation when he/she get below exception at the login screen.

 “User doesn’t have login rights”

Possible Cause: 

The above error usually occurs when the user doesn’t have login rights for either Management console or Point of Sale.

Proposed Solution:


Verify that the concerned user has valid rights allotment for logging into the application. You can check the configuration with the below steps: -

1.Open the Management console at Enterprise and login with user 1.
2.Go to Administration >> Authorization >> Security User
3.Select the concerned User and click on edit.
4.Select the Security Role that is assigned to the concerned User and press F4 (Edit Option).


5.Click on Assign Security Rights.


6.Expand System initialization row and find the option Login MC and Login POS. Here YES means User has a right to Login the MC or POS and NO means User doesn’t have right to Login the MC or POS