Not able to Login . Getting an error "User does not have a valid license to login"

Not able to Login . Getting an error "User does not have a valid license to login"

Problem: 
At time end user may face a situation when he/she get below exception at the login screen.

“User does not have a valid license to login” 

Possible Cause: 

The above error usually occurs when the user doesn’t have the license to log in either Management console or Point of Sale.

Proposed Solution:

Verify that the concerned user has valid license allotment for logging into the application. 

You can check the configuration with the below steps: -

1.Open the Management console at Enterprise and login with SuperUser Or with Login "1".
2.Go to Administration >> Authorization >> Security User
3.Select the concerned User and click on edit.
 
4. Check the Has License checkbox. This must be selected.

If this is not selected, select this setting and save the results. Once use details are updated, try logging with the problematic user and it should not face the issue anymore.