Not able to login at MC. Error "License entitlement violation. Please login with user 1 "

Not able to login at MC. Error "License entitlement violation. Please login with user 1 "

Problem:  

Users not able to login to Management Console due to error "License entitlement violation. Please login with user 1 on iVend Enterprise to fix the issue" as shown below:

Cause:

Below are a few of the know reasons causing this issue.
  1. This error is usually caused by having more records (e.g. warehouse, stores or users) created than the license entitlement allows.
  2. Non Licensed features are configured in the system. E.g. Handheld Devices.
  3. Specific store reports the issue after a change /update in the license at Enterprise server.

 Investigation:

As a very first step, you need to review the License Entitlements for the customer.
This can be verified from the “My License Entitlements” screen. This can be accessed from the below path.
 Management Console >Administration>IT Administration
 
(Sample Screenshot)
 
Once License details are noted, next to see the exact issue, view the Management Console log at the concerned machine. It will tell you exactly what is causing the license entitlement error.  The default location of the Management Console log is below:
C:\Users\[LoggedInUser]\AppData\Local\CitiXsys\CXS.Retail
 

Resolution(s): 

  1. Based on the Management Console log you may get to know of any license entitlement violation. E.g. “Management Console license count exceeded”. Such exception points out that, more than allowed license components have been allotted in the system.  In such a case, allotted Management Console licenses are to be reviewed among Security Users; and the ones, which are no more needed need to be revoked to fix the issue.
  2. If there are any Non-licenses feature has been configured that it needs to be removed from the system. e.g. Do not have a valid license for Handheld.
  3. If the issue has been reported at any specific store after a change in the license at Enterprise, then make sure that updated license information is successfully replicated from Enterprise serve to Store.

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