Getting error "DI: No matching record found" in integration failure monitor.

Getting error "DI: No matching record found" in integration failure monitor.

Problem Statement

Record stuck in integration failure monitor having the error 


DI: No Matching Records Found”.


Possible Cause with Resolution

Some of the possible causes with resolution are listed below:


Cause 1-Related item does not exist in SAP or marked deleted from SAP.

Check details of items associated with a stuck transaction ( can be checked by expanding failed transaction in Integration failure log) and look out for that item in SAP, if it is active or not.


Cause 2-Tax code accounts not defined in SAP.

Check details of tax associated with a stuck transaction (can be checked by expanding failed transaction in Integration failure log) and lookout for that item in SAP, if it exist or not, or if exists then must be active.


Cause 3-G/L accounts not defined.

Please check the same in the G/L Account Determination section under the Administration >> Setup >> financial. Also check details of the warehouse associated with the stuck transaction (can be checked by expanding the failed transaction in the Integration failure log) and in SAP, if all GL accounts have been defined for that warehouse. (Warehouse screen, accounting tab).


Cause 4- Sales Person missing in SAP.

Check detail of Sales Person associated with the stuck transaction (can be checked by expanding failed transaction in Integration failure log) and verify same against the salesperson details in SAP (if concerned Sales person exist or not, or if exists then must be active)


Cause 5-Freight accounts not defined.

Check for any surcharge associated with the stuck transaction (can be checked by expanding failed transaction in Integration failure log) and verify if concerned freight is available in SAP or not.


Case Study

Getting the error “DI: No Matching Records Found (ODBC - 2028)” in the integration failure monitor from iVend to SAP.


Cause

The G/L account was not mapped correctly in the Item Master.

The customer had changed the  "set g/l accounts by" setting for certain products to "Item Group" ( G/L account for item group was not defined) .

Records were failing as G/L account was not found. 


Resolution

To fix the issue, set g/l accounts by property of products was changed to Warehouse  (G/L account for the warehouse was defined) .  Go to SAP > item master data > Select the item > inventory data > set g/l accounts by-Warehouse (Set according to the transaction).


Note: The setting "set g/l accounts by " can be seen with different text as well e.g. "Set Inv. Method by"