Getting an error Product is locked for this warehouse at POS

Getting an error Product is locked for this warehouse at POS

Problem: 

Getting an error “Product is locked for this warehouse” while adding the product at POS.

( Refer screenshot below )



Cause:

The above error usually occurs when the concerned product is locked for the selling warehouse.


Resolution: 

Product configuration need to be updated to resolve above reported exception


Steps: 

Follow the below steps to update the configuration to resolve the exception. 


  1. Open the Management console.

  2. Go to Operations > > Inventory >> Product

  3. Choose the concerned product and click on “view inventory”.

  4. Look for the checkbox Locked.

  5. Unchecked the checkbox for the concerned warehouse.

  6. Once the updated configuration is saved, update the connection manager and re-launch the POS.

  7. Select the concerned item at POS for selling. You should not face the error anymore.