Failed to connect to the license server or Operations server.

Failed to connect to the license server or Operations server.

Problem Statement:

Failed to connect to the license server or Operations server.


Proposed Solution/Workaround:

Need to ensure License Tool installation and License Activation is done with Database Server.


Steps if any :

With iVend Configuration Manager, under Connection Manager we pass Database Server Adress and Database Name.


Now when we start the Management Console for the first time, it checks for License Information on Same Server mentioned in the Connection Manager and tries to update iVend Database relevant database tables accordingly.


Since the CXS License Administration Tool is not installed with the Database Server machine, it might cause a problem. So it's recommended to have a License Administration Tool installed with the Database Server.


Note: At times, Database Server and Application Server might be same but still get an error.

In such case, need to ensure Registry key: HKEY_CURRENT_USER\Software\FLEXlm License Manager> CITIXSYS_LICENSE_FILE should have Data set as Server Name or IP where License Admin Tool is installed.