Problem:
Management Console could not be launched after initializing the store
While Initialization a new store , getting error message “Invalid column name 'CustomerDisplayKey' or Invalid column name 'IsCustomerDisplayEnabled’” while launching the Management console.
Possible Cause:
The error may occur if there is difference in the version of newly installed store's and Enterprise. Possible cause is a faulty installation of store.
Procedure:
1.Run the query Select * from CfgVersion at Enterprise database as well as at the store database to confirm the Database version.
2.Compare the result and possibility is that the newly set store has different iVend version.( iVend version should be same at the both Enterprise and store servers).
3.If difference is found, it is suggested to re-install and re-initialize the Store once.
In case the issue still persists then please share the Management console Log File.
Path: - C:\Users\loggedinuser\AppData\Local\CitiXsys\CXS.Retail