******Internal to CitiXsys******Environment:
iVend 6.5 update 6 with SAP B1 9.2
Problem statement:
Duplicate replication entry blocking replication from Store to HO
Symptoms:
Error in Replication log :

Violation of PRIMARY KEY constraint 'PK_ReplicationTransaction'. Cannot insert duplicate key in object 'dbo.RepReplicationTransaction'. The duplicate key value is (22000000000923477).
The statement has been terminated. for record number:1000000000000018
Resolution/Work Around:
Delete the duplicate record from HO DB Repreplicationtransation table in order to make room for new record from store.

Note : take table backup before removing the record and check thoroughly.
Recommendations/Suggestion:
This is resolved in latest version of iVend i.e 6.6